1. MikePritchard
  2. Sherlock Holmes
  3. Commercial Templates
  4. Tuesday, 11 January 2022
  5.  Subscribe via email
I love your themes, you make me look like a hero : )

But on this install of the Colette theme on J3 with up to date everything, running php 7.4...
the mobile menu anchor links makes the scroll bar disappear on Firefox and Chrome.

Not all the time but if you click on any link other than the home link. you'll see the problem.

I tried a different anchor link (coded it inside a module) but had the same problem. With our without the full url it still happens.

I don't have any extensions installed other than what came with the theme.

Got any idea how to fix this?
Thanks much!
Accepted Answer Pending Moderation
0
Votes
Undo
Hello

Thank you for the kind words :)

Would you have a URL to an example of this issue?

Ciaran
  1. more than a month ago
  2. Commercial Templates
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
wow, i was trying hard to get all the details info my message but I forgot the most important one: https://forcebuilderscustomhomes.com/
sorry about that.
  1. more than a month ago
  2. Commercial Templates
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
Thank you Mike

Could try replacing your link without the URL, just using for example...

#top2_modules


Note you can also add the following to your templates settings Custom CSS field to apply a smooth transition when clicking an anchor..

html {
scroll-behavior: smooth;
}


Ciaran
  1. more than a month ago
  2. Commercial Templates
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
love the smooth scroll, thanks for that. Yes I tried the above, on the What We Offer link and it didn't work. Got any other ideas?

But I did find this in my custom css field, I must have added it awhile ago, think this would mess it up?

/* keep top logo bar small */
.logo {
padding: 15px 0;
}
.logo img {
max-width: 75%;
}
/*tighten footer */
.base-1{margin-bottom:-44px;}

.layerslideshow-title{
text-shadow: 2px 2px 4px #000000;
}

.layerslideshow-caption{
text-shadow: 0px 1px 2px #000;
font-weight:bold;
font-size:20px;
}
.hornav .menu .item-616{float:left;}/* to fix things to do to float to the left on top menu */



@media (max-width: 520px){
h1, h2{letter-spacing:1px;}
}
  1. more than a month ago
  2. Commercial Templates
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo
Hey Mike

It is unlikely that the issue is related to any CSS. May I suggest sending temporary administration access to your Joomla installation to [email protected] and we will examine this issue further. For our reference please paste a link to this post in your email.

Ciaran
  1. more than a month ago
  2. Commercial Templates
  3. # 5
Accepted Answer Pending Moderation
0
Votes
Undo
Thank you Mike

We have amended the issue by adding the following to the Custom CSS field of your template settings...

[id] {
scroll-margin-top: 100px;
}


Ciaran
  1. more than a month ago
  2. Commercial Templates
  3. # 6
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!

Join Our Newsletter

* indicates required
We respect your privacy and do not tolerate spam and will never sell, rent, lease or give away your information (name, email, number, etc.) to any third party. Nor will we send you unsolicited email.
Joomla51 - Mullaghmore, Co. Sligo, Ireland
Joomla51.com is not affiliated with or endorsed by the Joomla! Project or Open Source Matters.
The Joomla! name and logo is used under a limited license granted by
Open Source Matters
the trademark holder in the United States and other countries.

We use cookies on our website. Some of them are essential for the operation of the site, while others help us to improve this site and the user experience (tracking cookies). You can decide for yourself whether you want to allow cookies or not. Please note that if you reject them, you may not be able to use all the functionalities of the site.

Ok